Applies To: The specific folder paths apply to TimeXtender version 20.5.* and later. However, the troubleshooting techniques apply to earlier versions (Discovery Hub) as well.
Symptoms
You are going though the initial setup of ODX Service and encounter the following error:
"Cloud Environment is corrupt"
The following folder is empty:
C:\Program Files\TimeXtender\ODX <version>\BACKLOG
i.e. there is no Backlog.sqlite file created yet.
Potential Cause
The ODX Service running on TimeXtender machine is unable to reach the Cloud Environment.
Troubleshooting
Open a PowerShell window on TimeXtender machine.
Test network connection from your TimeXtender machine to the following servers:
ODX Server Environment (Database Server at port 1433):
test-netconnection timextender-repositories.database.windows.net -port 1433
ODX Secret Validation (HTTPS port 443):
test-netconnection timextender-api.azurewebsites.net -port 443
Below is an example of successful network connection.
For additional error details, review Windows Event Viewer application log and filter it for TimeXtender ODX Service events.
Solution
If the above connection test fails, review the networking, ports and communication on your TimeXtender machine with your IT/ network or security administrator.
References
Current list of TimeXtender servers are listed here:
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