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Scheduler stops working when changing repository

Note:  This is an old article.  However, the troubleshooting tips may still apply to newer versions. 

Symptoms

After creating a new repository and deleting the old, the TX scheduler service fails with an error containing the following line:

Service cannot be started. System.Data.SqlClient.SqlException (0x80131904): Cannot open database "projectRepository" requested by the login. The login failed. 

Cause

The scheduler service is trying to use the old repository.

Resolution

To resolve this issue, the scheduler needs to be pointed to the correct repository.

  1. Log in as the account running the scheduler service.
  2. Open TX
  3. A message box should appear to warn you that TX cannot find the repository. Click OK and the Project Repository dialogue box appears.
  4. Adjust your repository settings and click OK
  5. Restart the scheduler service.

If you are not allowed to log on as the user that runs the scheduler, see this article on how to change the repository settings.


This article applies to: timeXtender 4.5, tX2012, TX2014. Last updated: 2014-03-28.

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