Symptoms
You receive an error like the following:
Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding. Error during Data Processing for Table: <TABLENAME> Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding. Stored Procedure: [dbo].[usp_XXXXXX_Clean] Parameters: @Debug = 0 @Version = 182 @LoadDate = 09-01-2012 16:59:06
Cause
If you do not change the default timeout settings, any query on the staging as well as the DW database will timeout after 100 seconds.
Resolution
To change the timeout setting and solve the described timeout problem do the following on the database in question (stage or DW):
- Right click on the staging/dw database in TX and select Edit.
- At the bottom of the window change the Command Timeout to a higher value, e.g. 3600 for a one hour timeout)
This article applies to: timeXtender 4.5, tX2012, TX2014.
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