Symptoms
The user interface looks blurry, items are very small or items are missing from the user interface. This may only happen when logged into a remote desktop session.
Error Message
None
Cause
Issues with display scaling.
The application is displayed in another display scaling factor than it was initially opened in
TimeXtender is DPI-aware, which means that it should display properly in the scaling factor of the primary monitor. However, if you move the window to a monitor with a different display scaling factor, Windows will scale the application. Since this basically resizes the application like you would enlarge a picture in a photo editor, this will make the application look slightly blurry. Even when text and UI elements look crisp, bitmap elements in the user interface, such as icons, might look blurry since they are not rendered for all scaling factors.
The application is displayed in a custom scaling factor
While there should not be issues with incorrect item size and missing items in standard scaling factors such as 125%, 150% or 200%, custom scaling sizes are not guaranteed to work.
Display scaling factor is more than 100% and TimeXtender version is below 20.10.12
TimeXtender 20.10.12 included numerous improvements and fixes to the application's scaling support. Earlier versions have issues in any scaling factor other than 100%.
Resolution
Ensure that your computer's display scaling factor is not custom and the same on all monitors.
- On the Start Menu, click the settings (gear) icon
- In Windows Settings, click System
- Ensure that the value in Change the size of text, apps, and other items list is the same for all monitors.
If you are having this issue on a remote desktop connection, this resolution will not work unless you follow these steps carefully:
- Sign out from your remote desktop connection. Simply "disconnecting" will not work. You must find the Sign out option under the start menu or power options and choose that exact option. This is because the connection must be completely reset for the fix to work properly.
- Adjust the scaling on your local machine.
- Reconnect to the remote desktop. The change should take effect.
TimeXtender version below 20.10.12
If your are using a TimeXtender version older than 20.10.12, consider upgrading to take advantage of the improvements to scaling support. If that is not an option, you can let Windows scale the application. As mentioned above, this will make the application look blurry. However, the application should be perfectly usable.
- Go to the folder where the application is installed. The default is
'C:\Program Files\TimeXtender\TimeXtender <version>' - Right click 'timextender.exe' and click Properties
- (for Windows 10, click on "Compatibility" tab)
- Click Change high DPI settings
- Select Override high DPI scaling behavior and click 'System (enhanced)' in the Scaling performed by list.
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